vim shift 3 关于开启VIM的Python支持 - Linux - 服务器之家

服务器之家

专注于服务器技术!
当前位置:首页 > 服务器系统 > Linux

vim shift 3 关于开启VIM的Python支持

发布时间:2017-04-21 来源:服务器之家

阅读 97

收藏 0

点赞 0

如果你要在VIM中增加诸如YouCompleteMe这一类的插件的话,那么你需要VIM有Python的支持,这个是在一开始编译的选项里指定的。具体操作如下:

一、先运行:vim --version |grep python如果发现是这样的:

HanDevServer:/opt/itest # /opt/iapps/vim/bin/vim --version |grep python

+cryptv +linebreak -python +viminfo

-cscope +lispindent -python3 +vreplace

说明没有加入Python支持,这个时候如果使用YouCompleteMe这个插件,就会出现这样的警告:

HanDevServer:/opt/itest/gotest # vi hello.go

YouCompleteMe unavailable: requires Vim compiled with Python 2.x support

二、解决方案是重新编译,加入--enable-pythoninterp=yes参数。如果想开启Python3支持,则--enable-python3interp=yes,所以最终的编译选项是:

HanDevServer:~handaoliang/src/vim74 # ./configure --prefix=/opt/iapps/vim --enable-multibyte --enable-pythoninterp=yes

参考: